Ducati Supersport 939 Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi

i bought my bike last year in feburary as demo bike with 4789km and factory warranty of 2 years in local dealership in croatia.

had some problems with dqs, was replaced under warranty.

in may 2019 with 9073km i had bbs failure during commute in city.

all lights flashing, nothing working and stuck in limp mode.

had to wait for a week to get new bbs, asked them what caused the failure and i was asked if i was riding in rain, that water could have caused it to fail?!

few weeks ago fuel gauge got rekt as well as tcs.

next day everything was fine, in service they found error code and told me to unplug bbs for few minutes if something like this happens again.

yesterday i went on vacation, in middle of highway i have lightshow on dashboard. Same as last year, no speedo, no fuel, no power, abs, tcs, dqs.

didnt ride or wash bike in last few days since it was raining and it was stuck in garage.

Battery is ok, and was connected to oem battery charger last week until it was recharged.

tried restarting bike few times and unpluging bbs as i was instructed, check engine is always on and all errors pop up after few kilometers and everything stops working.

anyone had problems like this?

seems to me this could happen again at any given time.

really disapoointed.

i paid for trackday for 27.7 to finally go on track this year, seems i wont get refund for that and will have to go to service instead :/
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
One more note:

when both failures happened it was sunny, no rain, and bike wasnt washed few days prior.
 

·
Super Moderator
Joined
·
5,966 Posts
@Jurazg Welcome, sorry about so many things going wrong!

There’s lots of info here about fuel gauge issues, and also advice about DQS issues that some riders have experienced.

But complete failure in limp mode is unusual.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Left bbs unplugged overnight since i was instructed to do so last time on service in case of glitches like these.

check engine is still on, everything works for few kilometers and then just goes haywire.

I have enough fuel and all fluids.

guess nothing from trackday and its back to service in limp mode. :/
 

·
Registered
Joined
·
716 Posts
Yes, I too wonder what BBS is.
 

·
Registered
Joined
·
1,512 Posts
Here’s something from the Ducati forum, the last post could help.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
BBS- black box system. Module in rubber mount right in the middle under the seat, supposedly controls almost everything?
At least that is what they told me in service last year, that only bbs died and other stuff was working fine. I asked them why it failed, did i do something wrong, they didnt know what caused the problem.
Since i got new one under warranty i hoped i would never have this issue again.
as for part number, its this one 38510721C
No water yesterday nor did i clean it in last 7 days, only chain lubing and windshield/fairings clean up with bit of water and soap to remove bugs.
Cleaned my bmw f700gs with miniwash for 4 years, never had a single problem.
Think im gonna call a truck for towing, really dont feel like driving 160kms without abs and tcs.
 

·
Registered
Joined
·
716 Posts
Personally, I’d have no problem riding without the ABC/TC nannies. Two of my bikes never had it and they do just fine.
 
  • Like
Reactions: Ed K

·
Super Moderator
Joined
·
5,966 Posts
Oh... BBC = ECU, lol...

Since they replaced the ECU already, it might be a wiring problem. And definitely should not need to unplug ECU! And everything should work when it rains! I don’t recall anyone else here having this particular problem since 2017...but Members plz chime in if I missed it.

Dealer needs to fix it since you’re under warranty. Have they checked the general wiring for kinks, cracks, etc?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
yeah well i paid for those features and i like to have a safety net in case things go south.
much worse is that i have no idea how fast im going since speedo isnt working, kilometers are stuck on 27450 and wont update.
no idea how much fuel is left in tank since indicator isnt working and odometer stopped recording so i dont know how many kilometers i did so i can appoximate how much i have left.

like you said @Ed K , i shouldnt have to worry about being caught in rain or after i wash my bike.

my experience so far is following: everything works great, but sooner or later some or all of the gizmos will fail and possibly wont work after restart.

called road assistance, they will pick up the bike tomorrow in the morning and drop it off in service free of charge since bike is under warranty.
 

·
Super Moderator
Joined
·
5,966 Posts
Great you have full coverage.

Btw, was the bike washed gently; not with a pressure washer?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
bike was washed few days ago only on fairings with cloth, water and soap. and chain with wd40+ motul lube.

was washed few times with miniwash during last year, had no problems whatsoever. using it from at least 40-50cm distance to just soak the bike and pressure to clean bugs and stuff from fairing.

like i mentioned, bmw f700gs was washed almost exclusively with miniwash and i had no issues.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
the issue was following.

rear brake pad melted and got stuck to disc, causing overheating when running and damaging abs sensor, which in turn disabled everything else.

new sensor incoming and brake pad replaced, no damage to disc.

idk how brake pad melted since i was riding on highway and didnt use rear brake, didnt feel any brake fade and there were no sounds and noise when braking.

i had to bleed rear brake twice after winter since there was air in the system and i couldnt brake.

maybe that was the issue?
 

·
Registered
Joined
·
1,512 Posts
Wow brake pad melted, I thought that would be almost impossible. Very lucky if there wasn’t any discolouration the the disc.
 

·
Super Moderator
Joined
·
5,966 Posts
Wonder if there is any connection to this... see post #12:

 

·
Registered
Joined
·
10 Posts
Discussion Starter #20
there were no recalls for my bike, checked it online even.

asked them about the condition of front discs and pads, said they are fine and that i should be good to go for track day next week, mount for gopro should arrive as well.

i found out about ever red extended warranty, will ask them if i can buy that given how things are going so far.
 
1 - 20 of 22 Posts
Top