Ducati Supersport 939 Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 · (Edited)
Got my red S 13 days ago. Had been waiting for 2 months and have been really satisfied with this bike.
Up untill today!

On my way after work, while driving the dash started to flash! Everything flashed.
Put in in Neutral, and thought it would be a good idea to turn the ignition off and on again to see if that helped.
Well, it didn't :( Dash still flashed, and I could not start the bike up again!
This was on the highway. Managed to find a safe spot and had to call the Ducati "rescueline". The bike got picked up and is now being driven to another dealer.
I could not make him drive the bike to the dealer I bougth it since it was 2km(!) further away than another dealer on the other side of the city :(

Really disappointed ... And by the way... it's my birthday today. : (

Here is what the screen looked like :
 

Attachments

·
Registered
Joined
·
828 Posts
That sucks man, let us know what went wrong. As far as that friggin tow driver, screw him, he SHOULDVE been more accommodating for you, SERIOUSLY only 2km wouldn't have killed him for christsakes.:|
 

·
Registered
Joined
·
886 Posts
That sucks man, let us know what went wrong. As far as that friggin tow driver, screw him, he SHOULDVE been more accommodating for you, SERIOUSLY only 2km wouldn't have killed him for christsakes.:|
I wonder if this was a limitation of Ducati's Roadside Service program, not of the tow driver?
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #4 ·
I wonder if this was a limitation of Ducati's Roadside Service program, not of the tow driver?
According to the person I talked to at the Road side service they always pick the closest dealer. Even though its just 2km :(
 

·
Registered
Joined
·
4,431 Posts
And your weather looks good for the netherlands, so no water logging causing faults. It's odd.
Going forward I will keep my ELM 327 and dda converter in my tankbag, certainly don't need that happening to me. ELM might allow me to clear the error.
 

·
Registered
Joined
·
2,357 Posts
Oh no that's not good. Let's hope it's just a dodgy ECM or something ands it's as simple as just replacing that unit.
 

·
Registered
Joined
·
77 Posts
Sad story. I remember we got our bikes on the same day. Hope it will be solved soon.
These type of issues is inherent to all these electronics & computerized stuff, I see more & more nice vehicles brand new stuck on the side of the road... arround 5% of the electronic devices going out of a standard factory are deficient (read this in a magazine about phones few time ago) ...
need a alt+ctrl+del function on our SS...
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #12 ·
Got a call from the pickup service and at least they decided to drive it the dealer I bought from after all. I was promised a call later today and I would also have a possibility to loan a bike while they are checking it.

Strange thing is that when this happened every switch on the left hand side still worked. Music played, and the indicators worked. But not emergency blinkers or starter on the right side.

Crossing my fingers that this doesn't take to long.
 

·
Registered
Joined
·
149 Posts
Wish you a belated happy birthday anyway. Good luck with your bike and keep us up to date
 
  • Like
Reactions: kokla55

·
Premium Member
Joined
·
5,240 Posts
Hey where's the dancer gone.....suffering with withdrawals here..
Apparently my pic host is holding me hostage for money! Figures. I'm going to look for another free host who doesn't have a limitation for "3rd party imbedding" bullcrap. What good is a host of pics if you can't use them?
 

·
Registered
Joined
·
4,431 Posts
Apparently my pic host is holding me hostage for money! Figures. I'm going to look for another free host who doesn't have a limitation for "3rd party imbedding" bullcrap. What good is a host of pics if you can't use them?
So you weren't willing to pay $300 in bitcoin :wink2:
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #18 ·
The dealer called me again yesterday after they did the first diagnostics on my bike. They found failure on 7 different functions and couldn't reset any of them.
I asked if maybe the ECU was the problem, but he told me they actually suspect that it is the LCD instrumental panel that is causing this. They have ordered a new one that is expected on tuesday, and IF this is the problem they will drive my bike to my home straight away.

For some reason I feel that the problem is something else than the LCD but I will know next week
 

·
Registered
Joined
·
998 Posts
That sucks. The one thing about being on the leading edge of technology is that there are often bugs that come with the initial product.
 
1 - 20 of 26 Posts
Top